Вопрос задан 11.07.2023 в 07:11. Предмет Информатика. Спрашивает Huseynov Kamil.

Напишите программу Паскаль. Найти сумму первых n в квадрате чисел​

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Жукова Рина.

===== PascalABC.NET =====

begin

 SeqGen(ReadInteger('N ='), n -> n * n, 1).Sum.Print

end.


0 0
Отвечает Скоробогатый Деня.

Прикрепляю код программы в файле.

program brainly;

var

 n, i :integer;

 summ :real;

begin

 Write('Введите n: ');

 ReadLn(n);

 for i := 1 to n do

   summ += power(i, 2);

 Write('Сумма квадратов первых ', n, ' чисел равна: ', summ);

end.


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на языке Паскаль для вычисления суммы квадратов первых n чисел:

pascal
program SumOfSquares; var n, i, sum: Integer; begin writeln('Введите число n:'); readln(n); sum := 0; for i := 1 to n do sum := sum + i * i; writeln('Сумма квадратов первых ', n, ' чисел:', sum); readln; end.

В этой программе мы объявляем переменные n, i и sum. Затем мы запрашиваем у пользователя ввод значения n. Затем мы инициализируем переменную sum значением 0.

Затем мы используем цикл for для прохода от 1 до n. На каждой итерации мы добавляем квадрат текущего значения i к переменной sum.

В конце программы мы выводим результат - сумму квадратов первых n чисел.

Вы можете запустить эту программу в среде разработки, поддерживающей язык Паскаль, чтобы получить результат.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос