
ЗАДАНИЕ НА ПАСКАЛЬ: Написать программу и определить, делиться ли число N на 23.


Ответы на вопрос

program del_na_23;
var
n:integer;
begin
write('Введите n 》 ');
read(n);
if n mod 23 = 0 then
write('Число ',n,' делится на 23')
else
write('Число ',n,' не делится на 23')
end.




Конечно! Вот пример программы на языке Паскаль, которая проверяет, делится ли заданное число N на 23:
pascalprogram DivideBy23; var N: Integer; begin writeln('Введите число N:'); readln(N); if N mod 23 = 0 then writeln(N, ' делится на 23') else writeln(N, ' не делится на 23'); readln; end.
Программа запрашивает у пользователя число N и затем проверяет его на делимость на 23 с помощью оператора mod
, который возвращает остаток от деления числа N на 23. Если остаток равен нулю, то число N делится на 23, и программа выводит соответствующее сообщение. В противном случае выводится сообщение, что число N не делится на 23.
Помните, что в языке Паскаль индексация массивов начинается с 0, поэтому вам потребуется правильно настроить среду разработки, чтобы компилятор использовал корректную версию языка.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili