Вопрос задан 11.07.2023 в 00:13. Предмет Информатика. Спрашивает Ковшечников Константин.

Написать на Python!!!! Напишите программу, которая в последовательности целых чисел определяет

количество чисел, кратных 5 или 9. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Программа должна вывести одно число: количество чисел, кратных 5 или 9.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Евтушенко Вікторія.

k = 0

i = 1

while i!=0:

   i = int(input())

   if i % 5 == 0 or i % 9 == 0:

       k+=1

print(k-1)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи можно использовать цикл while для чтения входных чисел до тех пор, пока не будет введен ноль. Внутри цикла будем проверять каждое число на кратность 5 или 9 и увеличивать счетчик, если число удовлетворяет условию. После завершения цикла выведем значение счетчика на экран.

Вот программа на Python:

python
def count_multiples(): count = 0 while True: num = int(input("Введите целое число (0 для окончания ввода): ")) if num == 0: break if num % 5 == 0 or num % 9 == 0: count += 1 return count result = count_multiples() print(f"Количество чисел, кратных 5 или 9: {result}")

Программа попросит вас вводить целые числа до тех пор, пока не введете 0. После ввода 0 программа выведет количество чисел, кратных 5 или 9, которые были введены.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос