
Вопрос задан 10.07.2023 в 17:51.
Предмет Информатика.
Спрашивает Chuchaev Mustafa.
Составьте программу в паскале, которая из трех чисел, введенных с клавиатуры, возводит в квадрат
положительные, а отрицательные оставляет без изменения. Дам 25 баллов! Помогите пожалуйста

Ответы на вопрос

Отвечает Прутикова Мария.
program plan;
var
a,b,c : real;
begin
readln(a,b,c);
if a >0 then
a := a *a;
if b >0 then
b := b *b;
if c >0 then
c := c *c;
end.



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на языке Паскаль, которая выполняет указанное действие:
pascalprogram SquarePositiveNumbers; var num1, num2, num3: real; begin writeln('Введите первое число:'); readln(num1); writeln('Введите второе число:'); readln(num2); writeln('Введите третье число:'); readln(num3); if num1 > 0 then num1 := sqr(num1); if num2 > 0 then num2 := sqr(num2); if num3 > 0 then num3 := sqr(num3); writeln('Результат:'); writeln('Первое число:', num1); writeln('Второе число:', num2); writeln('Третье число:', num3); readln; end.
Программа запрашивает три числа с клавиатуры, затем проверяет каждое число на положительность. Если число положительное, то оно возводится в квадрат с помощью функции sqr()
, иначе число остается без изменений. Результат выводится на экран.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili