Даю 20б помогите составить правильно программу в Паскаль В массиве хранится информация о
количестве осадков, выпавших за каждый день июня. Определить общее количество осадков, выпавших за каждую декаду этого месяца. Ребят, проверочная, решите правильноОтветы на вопрос
Ответ:program qwe;
var
a:array[1..30] of integer; //объявляем массив а целых чисел из 30 элементов
i,k,j:integer; //объявляем i,k,j целого типа
begin
randomize; //подключаем генерирование случайных чисел
for i:=1 to 30 do //циклом от 1 до 30 включительно
begin
a:=random(50); //заполняем каждый элемент массива случайными числами
//от 0 до 50 (не включая 50)
write(a,' '); //выводим в строчку полученный элемент и
//добавляем после него пробел
end;
writeln; //переход на новую строку
for j:=1 to 3 do //циклом от 1 до 3 влючительно
//т. к. в июне 30 дней, то и декад - 3
begin
k:=0; //обнуляем k, что бы каждую декажу считать заново
for i:=(1+10*(j-1)) to 10+10*(j-1) do //циклом от начала каждог десятка
//например с 1, с 11 и с 21 по конец каждого десятка
//например по 10, по 20 и по 30
k:=k+a; //к тому что у нас было прибавляем очередной элемент
writeln(k,' осадков за ',j,' декаду'); //выводим результат
end;
readln; //для задержки экрана.
end.
код иногда некорректно отображается на "ответах"
Конечно, я помогу вам составить программу на языке Паскаль для решения данной задачи. Предположим, у нас есть массив rainfall из 30 элементов, где каждый элемент представляет количество осадков для определенного дня июня.
pascalprogram RainfallTotal; const DaysInMonth = 30; DecadeDays = 10; Decades = DaysInMonth div DecadeDays; var rainfall: array[1..DaysInMonth] of Integer; decadeTotal: array[1..Decades] of Integer; i, day, decade: Integer; begin // Ввод данных for i := 1 to DaysInMonth do begin Write('Введите количество осадков для ', i, '-го дня июня: '); Readln(rainfall[i]); end; // Обнуление сумм декад for decade := 1 to Decades do decadeTotal[decade] := 0; // Расчет сумм декад for day := 1 to DaysInMonth do begin decade := (day - 1) div DecadeDays + 1; decadeTotal[decade] := decadeTotal[decade] + rainfall[day]; end; // Вывод результатов Writeln('Суммы осадков за каждую декаду июня:'); for decade := 1 to Decades do Writeln('Декада ', decade, ': ', decadeTotal[decade], ' мм'); end.
В данной программе мы используем два массива: rainfall для хранения количества осадков на каждый день июня и decadeTotal для хранения суммы осадков за каждую декаду месяца. Мы сначала вводим данные, затем расчитываем суммы осадков для каждой декады и, наконец, выводим результаты на экран.
Похожие вопросы
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
