Вопрос задан 10.07.2023 в 07:16.
Предмет Информатика.
Спрашивает Нугаева Ксюша.
Составить программу на Паскаль: Даны два неравных числа. Меньшее из этих чисел возвести в куб, а
большее уменьшить на 35.Ответы на вопрос
Отвечает Добровольская Анеля.
program abc;
var
a,b : integer;
begin
writeln('Введите числа а и б');
readln(a,b);
if a >b then
begin
writeln(b*b*b);
writeln(a+35);
end;
if b > a then
begin
writeln(a*a*a);
writeln(b+35);
end;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на языке Паскаль, которая выполняет описанные вами действия:
pascalprogram CubeAndSubtract; var num1, num2, smaller, larger: real; begin writeln('Введите два числа:'); readln(num1, num2); if num1 < num2 then begin smaller := num1; larger := num2; end else begin smaller := num2; larger := num1; end; writeln('Меньшее число в кубе: ', smaller * smaller * smaller); writeln('Большее число - 35: ', larger - 35); readln; end.
Просто скопируйте этот код в среду программирования на Паскале (например, Free Pascal) и выполните его. Программа запросит у вас ввести два числа и выведет результаты.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
