
Решить в Pascal ABC Дан целочисленный массив из n элементов. Элементы массива могут принимать
целые значения от 0 до 10 000 включительно (такие числа будет вводить пользователь, это проверять не нужно). Напишите программу, которая находит максимальный из оканчивающихся на 3 элементов массива, затем увеличивает все элементы массива, кратные 8, на значение этого элемента, и выводит в строку. Если в массиве нет оканчивающихся на 3 элементов, он остаётся без изменений. Например, из массива7, 23, 18, 24, 33, 48, 80программа должна получить массив7, 23, 18, 57, 33, 81, 1

Ответы на вопрос

const n = 7;
var a: array [1..n] of integer;
i, max: integer;
begin
for i := 1 to n do
begin
write('Введите ', i, ' элемент: ');
readln(a[i]);
end;
max := 0;
for i := 1 to n do
begin
if (a[i] mod 10 = 3) and (a[i] > max) then
max := a[i];
end;
for i := 1 to n do
begin
if (a[i] mod 8 = 0) then
a[i] := a[i] + max;
end;
for i := 1 to n do
begin
write(a[i], ' ');
end;
writeln();
end.



Привет! Вот пример программы на Pascal ABC, которая решает данную задачу:
pascalprogram MaxAndModifyArray; const MAX_SIZE = 10000; MAX_ELEMENTS = 100; var arr: array[1..MAX_ELEMENTS] of integer; n, i, maxEnding3, countEnding3: integer; procedure ReadArraySize; begin writeln('Введите размер массива (n): '); readln(n); if (n < 1) or (n > MAX_ELEMENTS) then begin writeln('Неверный размер массива. Допустимый диапазон: 1 - ', MAX_ELEMENTS); ReadArraySize; // Повторный ввод размера массива end; end; procedure ReadArrayValues; begin writeln('Введите элементы массива:'); for i := 1 to n do readln(arr[i]); end; procedure FindMaxEnding3; begin maxEnding3 := -1; countEnding3 := 0; for i := 1 to n do begin if arr[i] mod 10 = 3 then begin if arr[i] > maxEnding3 then maxEnding3 := arr[i]; Inc(countEnding3); end; end; end; procedure ModifyArray; begin if countEnding3 > 0 then begin writeln('Максимальный элемент, оканчивающийся на 3: ', maxEnding3); for i := 1 to n do begin if arr[i] mod 8 = 0 then arr[i] := arr[i] + maxEnding3; end; end else writeln('В массиве нет элементов, оканчивающихся на 3.'); end; procedure PrintModifiedArray; begin writeln('Измененный массив:'); for i := 1 to n do write(arr[i], ' '); end; begin ReadArraySize; ReadArrayValues; FindMaxEnding3; ModifyArray; PrintModifiedArray; end.
Эта программа сначала читает размер и элементы массива, затем находит максимальный элемент, оканчивающийся на 3, увеличивает элементы, кратные 8, на это значение и выводит измененный массив.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili