Вопрос задан 09.07.2023 в 19:03.
Предмет Информатика.
Спрашивает Гамандий Света.
Без повторений С заданного массива целых чисел нужно удалить все дублирования элементов. То есть
из нескольких одинаковых элементов в массиве остается только элемент с наименьшим индексом. Входные данные В первой строке записано число N. В следующей строке записано N целых чисел. Все числа по модулю не превышают 100. Выходные данные Вывести элементы массива без повторений в одной строке через пробел, не меняя первоначальный порядок. Входные данные #1 7 0 1 -2 1 0 0 3 Выходные данные #1 0 1 -2 3 На С++Ответы на вопрос
Отвечает Воробьев Артём.
Ответ:
#include <iostream>
using namespace std;
int main()
{
int i,j,N;
cin >> N;
int* A = new int[N];
for (i = 0; i < N; i++) cin >> A[i];
for (i = 0; i < N; i++)
{
for (j = 0; j < i; j++)
if (A[i] == A[j]) break;
if (i==j) cout << A[i] << " ";
}
return 0;
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример кода на C++, который решает данную задачу:
cpp#include <iostream>
#include <unordered_set>
#include <vector>
int main() {
int N;
std::cin >> N;
std::vector<int> numbers(N);
for (int i = 0; i < N; ++i) {
std::cin >> numbers[i];
}
std::unordered_set<int> seen_numbers;
std::vector<int> result;
for (int num : numbers) {
if (seen_numbers.find(num) == seen_numbers.end()) {
seen_numbers.insert(num);
result.push_back(num);
}
}
for (int num : result) {
std::cout << num << " ";
}
return 0;
}
Вы можете вставить этот код в среду разработки C++ (например, Visual Studio, Code::Blocks, или другие), скомпилировать и запустить для того, чтобы решить задачу удаления дубликатов из массива чисел.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 16
Информатика 13
Информатика 39
Информатика 160
Информатика 65
Информатика 44
Информатика 84
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
