Вопрос задан 09.07.2023 в 14:46. Предмет Информатика. Спрашивает Орынбасаров Елдос.

3.На вход программе подается натуральное число. Найдите произведение ненулевых цифр числа.Питон

помогите плиз​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Менский Лёша.

from functools import reduce

print(reduce(lambda x,y: x*y, [int(x) for x in input() if x != '0']))

Или менее красиво, но зато так как потом попросили:

a: int = 1

for x in input():

 a *= int(x) if x != '0' else 1

print(a)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Python, которая находит произведение ненулевых цифр натурального числа:

python
def product_of_non_zero_digits(number): product = 1 while number > 0: digit = number % 10 if digit != 0: product *= digit number //= 10 return product # Вводим натуральное число от пользователя num = int(input("Введите натуральное число: ")) result = product_of_non_zero_digits(num) print("Произведение ненулевых цифр числа:", result)

Просто скопируйте этот код в свою среду разработки Python и запустите его. Программа запросит у вас ввод натурального числа и выведет произведение его ненулевых цифр.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос