Напишите программу на Pascal: Напишите среднее значение целых положительных чисел, которые вводятся
с клавиатуры (окончание ввода-ввод числа 0)Ответы на вопрос
Ответ:
//Pascal
var a,i,s,n:integer;
begin
s:=0;
n:=0;
repeat
readln(a);
if a>0 then begin
n:=n+1;
s:=s+a;
end;
until a = 0;
writeln('Сумма ',s:5,' Среднее арифметическое ',s/n);
end.
(ПОМОЕМУ ТАК) (Я НЕСОВСЕМ УВЕРЕН)
Ответ:
--- PascalABC.NET 3.6.2 ---
begin
ReadSeqIntegerWhile(p -> p <> 0).Where(p -> p > 0).Average.Println;
end.
Конечно! Вот пример программы на языке Pascal, которая вычисляет среднее значение положительных целых чисел, вводимых с клавиатуры, и прекращает ввод при вводе числа 0:
pascalprogram AveragePositiveNumbers; var num, sum, count: integer; average: real; begin sum := 0; count := 0; writeln('Введите положительные числа (введите 0 для окончания):'); repeat readln(num); if num > 0 then begin sum := sum + num; count := count + 1; end; until num = 0; if count > 0 then begin average := sum / count; writeln('Среднее значение положительных чисел: ', average:0:2); end else writeln('Нет положительных чисел для расчета среднего значения.'); readln; end.
Программа просит пользователя вводить положительные числа. Ввод чисел продолжается до тех пор, пока не будет введен 0. После окончания ввода программа вычисляет среднее значение положительных чисел и выводит результат на экран. Если не было введено ни одного положительного числа, программа выведет сообщение о том, что нет чисел для расчета среднего значения.
Обратите внимание, что в данной программе предполагается, что пользователь будет вводить только целые числа.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
