Вопрос задан 07.07.2023 в 16:18. Предмет Информатика. Спрашивает Смирнов Егор.

Составить программу на языке Паскаль для определения среднего арифметического двух чисел a и b,

если a положительное и частное (a/b) в противном случае. ПОЖАЛУЙСТА, ОЧЕНЬ НАДО!!!!
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Лодди Денис.

Ответ:

program f;

var a,b,c,d:real;

begin

writeln('Введите два числа');

readln(a,b);

c:=(a+b)/2;

d:=a/b;

if a>0 then writeln(c)

else writeln(d);

end.

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке Паскаль для определения среднего арифметического двух чисел a и b:

pascal
program CalculateAverage; var a, b: real; // используем тип real для вещественных чисел result: real; begin writeln('Введите два числа: '); readln(a, b); if a > 0 then result := (a + b) / 2 else result := a / b; writeln('Результат: ', result:0:2); // выводим результат с двумя знаками после запятой end.

Скопируйте этот код в вашу среду программирования на Паскале и выполните его. Программа попросит вас ввести два числа, а затем вычислит и выведет среднее арифметическое или частное в зависимости от значения a.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос