Вопрос задан 07.07.2023 в 14:51.
Предмет Информатика.
Спрашивает Barbq-Junior Андрюха.
Напишите программу, которая считает сумму четных чисел среди заданных целых чисел a, b, c (числа a,
b, c вводятся с клавиатуры).Ответы на вопрос
Отвечает Тиханов Радимир.
Ответ:
var
a, b, c, s: integer;
begin
readln(a, b, c);
if a mod 2 = 0 then s += a;
if b mod 2 = 0 then s += b;
if c mod 2 = 0 then s += c;
writeln(s);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Python, которая считает сумму четных чисел среди заданных целых чисел a, b и c, введенных с клавиатуры:
pythona = int(input("Введите число a: "))
b = int(input("Введите число b: "))
c = int(input("Введите число c: "))
sum_even = 0
if a % 2 == 0:
sum_even += a
if b % 2 == 0:
sum_even += b
if c % 2 == 0:
sum_even += c
print("Сумма четных чисел:", sum_even)
В этой программе мы используем функцию input() для ввода значений a, b и c с клавиатуры. Затем мы проверяем каждое число на четность с помощью оператора % (остаток от деления на 2). Если число четное, мы добавляем его к переменной sum_even. Наконец, мы выводим сумму четных чисел на экран с помощью функции print().
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 19
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
