Напишите программу в паскале пж!! Известно, сколько очков заработала каждая из 20 команд в
отборочном туре игры КВН. В финал выходят только 5 команд. Выведите на экран очки команд, вышедших в финал.Ответы на вопрос
Ответ:
var a:array[1..20] of integer;
i, c:integer;
Begin
writeln('Введите очки команд: ');
For i:=1 to 20 do readln(a[i]);
for i:=2 to 20 do begin
if (a[i] < a[i-1]) then begin
c:=a[i];
a[i]:=a[i-1];
a[i-1]:=c;
End;
end;
for i:=1 to 5 do write(a[i], ' ');
End.
Ответ:
var a:array[1..20] of integer; i, c:integer;Begin writeln('Введите очки команд: '); For i:=1 to 20 do readln(a[i]); for i:=2 to 20 do begin if (a[i] < a[i-1]) then begin c:=a[i]; a[i]:=a[i-1]; a[i-1]:=c; End; end;for i:=1 to 5 do write(a[i], ' ');End.
Объяснение:
.
Конечно, вот пример программы на языке Pascal, которая поможет вам выполнить данную задачу:
pascalprogram KVN_Finalists; var scores: array[1..20] of Integer; finalists: array[1..5] of Integer; i, j, temp: Integer; begin writeln('Введите очки каждой из 20 команд:'); for i := 1 to 20 do begin write('Команда ', i, ': '); readln(scores[i]); end; // Сортировка очков команд по убыванию for i := 1 to 19 do begin for j := i + 1 to 20 do begin if scores[i] < scores[j] then begin temp := scores[i]; scores[i] := scores[j]; scores[j] := temp; end; end; end; // Выбор 5 команд с наивысшими очками for i := 1 to 5 do begin finalists[i] := scores[i]; end; writeln('Команды, вышедшие в финал:'); for i := 1 to 5 do begin writeln('Команда ', i, ' - ', finalists[i], ' очков'); end; end.
Программа сначала считывает 20 очков команд из ввода. Затем она сортирует очки по убыванию и выбирает первые 5 команд с наивысшими очками. Наконец, программа выводит на экран список команд, вышедших в финал, с их очками.
Примечание: Это простой пример для демонстрации. В реальной практике, важно учесть ввод данных, обработку ошибок и другие аспекты программирования.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
