Вопрос задан 07.07.2023 в 07:47. Предмет Информатика. Спрашивает Власова Анна.

50 БАЛЛОВ!!!!!! СРОЧНО.... Написать программу паскаль. Дано n натуральных чисел которые вводятся по

одному найти количество чисел последняя цифра которых равна 5
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кудряшева Ирина.

// PascalABC.NET

begin

 var n := ReadInteger('n =');

 ReadSeqInteger('Вводите:', n)

     .Count(p -> p mod 10 = 5)

     .Print

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Pascal, которая выполняет указанную задачу:

pascal
program CountNumbersEndingWith5; var n, num, count: integer; begin writeln('Введите количество чисел:'); readln(n); count := 0; writeln('Введите ', n, ' натуральных чисел:'); for var i := 1 to n do begin readln(num); if num mod 10 = 5 then count := count + 1; end; writeln('Количество чисел, оканчивающихся на 5: ', count); end.

Вы можете скопировать этот код и вставить его в среду разработки Pascal (например, Free Pascal) для выполнения. Программа сначала запросит количество чисел, затем будет просить ввести сами числа по одному. После ввода всех чисел, программа выведет количество чисел, оканчивающихся на 5.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос