Вопрос задан 07.07.2023 в 07:01.
Предмет Информатика.
Спрашивает Менгельбаева Алина.
PascalABC. Написать программу, в которой выполняются следующие действия: 1. с клавиатуры вводится
имя 1-го человека; 2. с клавиатуры вводится вес 1-го человека; 3. с клавиатуры вводится имя 2-го человека; 4. с клавиатуры вводится вес 2-го человека; 5. программа выводит имя более тяжелого человека (при равенстве весов выводится имя 2-го человека); 6. в том случае, когда вес какого-либо человека или обоих не находится в пределах от 3 до 150 программа выводит только сообщение «ошибка».Ответы на вопрос
Отвечает Усцова Софья.
Ответ:
var
a, b:String;
c, d:Integer;
begin
readln(a);
readln(c);
if (c < 3) or (c > 150)
then begin
writeln('Ошибка');
exit;
end;
readln(b);
readln(d);
if (d < 3) or (d > 150)
then begin
writeln('Ошибка');
exit;
end;
if c > d then
writeln(a)
else
writeln(b);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на PascalABC, которая выполняет указанные вами действия:
pascalprogram CompareWeights; var name1, name2: string; weight1, weight2: real; begin writeln('Введите имя 1-го человека:'); readln(name1); writeln('Введите вес 1-го человека:'); readln(weight1); writeln('Введите имя 2-го человека:'); readln(name2); writeln('Введите вес 2-го человека:'); readln(weight2); if (weight1 >= 3) and (weight1 <= 150) and (weight2 >= 3) and (weight2 <= 150) then begin if weight1 > weight2 then writeln('Более тяжелый человек: ', name1) else if weight1 < weight2 then writeln('Более тяжелый человек: ', name2) else writeln('Более тяжелый человек: ', name2); end else writeln('Ошибка'); end.
Программа сначала запрашивает имя и вес первого человека, затем имя и вес второго человека. Затем она сравнивает веса и выводит имя более тяжелого человека или сообщение об ошибке, если вес не находится в допустимых пределах от 3 до 150.
Похожие вопросы
Информатика 81
Информатика 98
Информатика 39
Информатика 143
Информатика 86
Информатика 13
Информатика 31
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
