Вопрос задан 05.07.2023 в 14:27. Предмет Информатика. Спрашивает Миллер Дарья.

Программирование на Python Количество пятерокНа вход программе подается последовательность целых

чисел от 1 до 5, характеризующее оценку ученика, каждое число на отдельной строке. Концом последовательности является любое отрицательное число, либо число большее 5. Напишите программу, которая выводит количество пятерок.Формат входных данныхНа вход программе подается последовательность чисел, каждое число на отдельной строке.Формат выходных данныхПрограмма должна вывести количество пятерок.​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кузбакова Асия.

Ответ:

--- Python 3.8.3 ---

import typing

from typing import Callable

def ReadSeqWhile(SeqType, predicate: Callable[[int], bool]):

   temp = SeqType(input())

   while predicate(temp):

       yield temp

       temp = SeqType(input())

def main():

   MarksList = ReadSeqWhile(int, lambda m: (m <= 5) and (m > 0) )

   fives = filter(lambda m: m == 5, MarksList)

   print(len(list(fives)))

   

if __name__ == "__main__":

   main()

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вы можете использовать следующий код на Python для решения задачи:

python
count_of_fives = 0 while True: num = int(input()) if num == 5: count_of_fives += 1 elif num < 0 or num > 5: break print(count_of_fives)

Программа начинает бесконечный цикл, в котором она читает ввод пользователя, преобразуя строку в целое число. Если введенное число равно 5, то увеличивается счетчик пятерок. Если введенное число отрицательное или больше 5, цикл завершается, и программа выводит количество пятерок.

Пример работы программы:

diff
4 5 3 5 5 2 -1 2 3 5 4 6 3 -2 2 1 5 5 -3

В этом примере программа подсчитает, что было введено 6 пятерок.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос