Вопрос задан 05.07.2023 в 14:27. Предмет Информатика. Спрашивает Попов Вова.

Программирование на python Сумма чиселНа вход программе подается последовательность целых чисел,

каждое число на отдельной строке. Концом последовательности является любое отрицательное число. Напишите программу, которая выводит сумму всех членов данной последовательности.Формат входных данныхНа вход программе подается последовательность чисел, каждое число на отдельной строке.Формат выходных данныхПрограмма должна вывести сумму членов данной последовательности.​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Михеев Артемий.

num = int(input())

sm = 0

while num > -1:

   sm += num

   num = int(input())

print(sm)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на Python, которая выполняет указанную задачу:

python
# Инициализация переменной для хранения суммы total_sum = 0 # Ввод чисел и подсчет суммы while True: num = int(input()) if num < 0: break total_sum += num # Вывод суммы print(total_sum)

Программа будет поочередно запрашивать ввод чисел от пользователя до тех пор, пока не будет введено отрицательное число. Затем она выведет сумму всех введенных положительных чисел.

Пример использования:

diff
2 4 6 -1

Вывод:

12
0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос