Составьте программу, которая для целого числа k (от 1 до 99), введенного вами, напечатает фразу
«Мне k лет», при этом в нужных случаях слово «лет» заменяя на слово «год» или «года». На языке Паскаль С использованием оператора switch, caseОтветы на вопрос
// PascalABC.NET
begin
var n := ReadInteger('Введите возраст (1-99):');
if not (n in 1..99) then
Print('Неверный возраст')
else if n in 10..20 then
Print('Мне', n, 'лет')
else
case n mod 10 of
1: Print('Мне', n, 'год');
2..4: Print('Мне', n, 'года');
else Print('Мне', n, 'лет')
end;
end.
Ответ:
var
Age : integer;
begin
Repeat
Write('Введите Ваш возраст: ');
Readln(Age);
until Age in [1..99];
if Age in [10..20] then Writeln('Мне ', Age, ' лет') else
case Age mod 10 of
1: Writeln('Мне ', Age, ' год');
2, 3, 4 : Writeln('Мне ', Age, ' года');
0, 5..9 : Writeln('Мне ', Age, ' лет');
end;
end.
Конечно, вот пример программы на языке Паскаль, которая выполняет описанную задачу:
pascalprogram AgePhrase; var k: integer; begin writeln('Введите целое число k (от 1 до 99): '); readln(k); case k of 1, 21, 31, 41, 51, 61, 71, 81, 91: writeln('Мне ', k, ' год'); 2, 3, 4, 22, 23, 24, 32, 33, 34, 42, 43, 44, 52, 53, 54, 62, 63, 64, 72, 73, 74, 82, 83, 84, 92, 93, 94: writeln('Мне ', k, ' года'); else writeln('Мне ', k, ' лет'); end; readln; end.
Эта программа сначала запрашивает у пользователя ввод целого числа k в заданном диапазоне, а затем использует оператор case для определения, какое слово (год, года или лет) следует использовать в зависимости от значения k.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
