Вопрос задан 14.05.2018 в 07:23. Предмет Информатика. Спрашивает Петришина Наташа.

Составьте программу, которая для числа K (от 1 до 99), введенного вами, напечатает фразу «Мне K

лет», где K – введенное число, при этом в нужных случаях слово «лет» заменяя на «год» или «года». Например, при K=70 «Мне 70 лет», при K=15 «Мне 15 лет», при K=23 «Мне 23 года», при K=31 «Мне 31 год».что значит until и case в этой задаче
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Пустельник Илиана.

Программа на Pascal
 var   Age : integer;
begin Repeat Write('Введите Ваш возраст: ');
Readln(Age); until Age in [1..99];
if Age in [10..20] then Writeln('Мне ', Age, ' лет')
else    case Age mod 10 of    1: Writeln('Мне ', Age, ' год');    
2, 3, 4 : Writeln('Мне ', Age, ' года');    
0, 5..9 : Writeln('Мне ', Age, ' лет');
end;
end.
программа на C++
#include <iostream> 
using namespace std; 
int main() 
{ 
setlocale(LC_ALL,"rus"); 
int k; 
cin>>k; 
if(k >0 && k<100) 
cout<<"Мне "<< k <<" лет"; 
system("pause >> void"); 
}

0 0
Отвечает Гамандий Света.

Var k:integer;
begin
     readln(k);
     case k of
          10..20: writeln('Мне ', k ,' лет');
     else
          case k mod 10 of
               1   : writeln('Мне ', k ,' год');
               2..4: writeln('Мне ', k ,' года');
          else writeln('Мне ', k ,' лет');
          end;
     end;
end.
//---------------
#include <iostream>
using namespace std;
int main()
{
    int k;
    cin >> k;
    if (k >= 10 && k <= 20)
        cout << "Мне " << k << " лет" << endl;
    else
        switch (k % 10)
        {
            case 1: cout << "Мне " << k << " год" << endl; break;
            case 2: cout << "Мне " << k << " года" << endl; break;
            case 3: cout << "Мне " << k << " года" << endl; break;
            case 4: cout << "Мне " << k << " года" << endl; break;
            default: cout << "Мне " << k << " лет" << endl; break;
        }
}
//----------------
case - оператор выбора

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос