
Вопрос задан 05.07.2023 в 09:08.
Предмет Информатика.
Спрашивает Романова Софья.
Задача на Паскале, срочно!!! Составьте программу определения в массиве B(30) минимального
элемента и его номера.

Ответы на вопрос

Отвечает Храмова Юля.
Ответ:
- var
- n, i: integer;
- B: array [1..30] of integer;
- begin
- Randomize;
- n := 1;
- for i := 1 to 30 do
- begin
- B[i] := Random(100);
- Write(B[i], ' ');
- if B[i]<B[n] then n := i;
- end;
- Writeln;
- Writeln('Номер: ', n);
- Write('Элемент: ', B[n]);
- end.
PascalABC.NET:
- begin
- var B := ArrRandom(30, -99, 99);
- var n := B.IndexMin;
- B.Println;
- Println('Номер:', n+1);
- Print('Элемент:', B[n])
- end.
Пример работы:





Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Pascal для определения минимального элемента в массиве B(30) и его номера:
pascalprogram FindMinElement; const N = 30; var B: array[1..N] of Integer; i, minElement, minIndex: Integer; begin writeln('Введите элементы массива B(30):'); for i := 1 to N do begin write('B[', i, ']: '); readln(B[i]); end; minElement := B[1]; minIndex := 1; for i := 2 to N do begin if B[i] < minElement then begin minElement := B[i]; minIndex := i; end; end; writeln('Минимальный элемент: ', minElement); writeln('Номер минимального элемента: ', minIndex); end.
Программа сначала запрашивает у пользователя 30 элементов массива B, затем находит минимальный элемент и его номер, выводит результат на экран.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili