Вопрос задан 05.07.2023 в 04:10.
Предмет Информатика.
Спрашивает Шавель Дмитрий.
РЕШИТЕ В JAVA, ПОЖАЛУЙСТА. Программа получает на вход последовательность целых неотрицательных
чисел, каждое число записано в отдельной строке. Последовательность завершается числом 0, при считывании которого программа должна закончить свою работу и вывести количество членов последовательности (не считая завершающего числа 0). Числа, следующие за числом 0, считывать не нужно. Формат входных данных Вводится последовательность целых чисел, заканчивающаяся числом 0. Формат выходных данных Выведите ответ на задачу. Sample Input: 1 7 9 0 5 Sample Output: 3Ответы на вопрос
Отвечает Madrid Real.
import java.util.Scanner;
public class Main
{
public static void main(String[] args) {
int counter = 0;
Scanner scanner = new Scanner(System.in);
int num = scanner.nextInt();
while (num != 0) {
counter++;
num = scanner.nextInt();
}
System.out.println(counter);
scanner.close();
}
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример решения данной задачи на языке Java:
javaimport java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
int count = 0;
int num;
while (true) {
num = scanner.nextInt();
if (num == 0) {
break;
}
count++;
}
System.out.println(count);
}
}
Эта программа считывает последовательность чисел с помощью класса Scanner. Она продолжает считывать числа до тех пор, пока не встретит число 0. После этого программа выводит количество чисел, считанных до этого момента (не включая число 0).
Похожие вопросы
Информатика 94
Информатика 78
Информатика 16
Информатика 15
Информатика 62
Информатика 18
Информатика 47
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
