Составить программу,которая вычисляет 3 степень числа,если это число больше 10,но меньше 20
Ответы на вопрос
Ответ:
C++
#include <iostream>
#include <math.h>
int main()
{
setlocale(LC_ALL, "ru");
int number, res;
std::cout << "Введите число: " << std::endl;
std::cin >> number;
if ((number > 10) && (number < 20))
{
res = pow(number, 3);
std::cout << number << " в 3-ей степени = " << res <<std::endl;
}
else
std::cout << "Вы ввели неподходящее число!" << std::endl;
return 0;
}
Объяснение:
Конечно! Вот пример программы на языке Python, которая вычисляет куб числа, если оно больше 10, но меньше 20:
pythonnumber = int(input("Введите число: "))
if number > 10 and number < 20:
result = number ** 3
print(f"Куб числа {number} равен {result}")
else:
print("Число не удовлетворяет условию (больше 10, но меньше 20)")
Программа запрашивает у пользователя ввести число, а затем проверяет, удовлетворяет ли оно условию (больше 10, но меньше 20). Если число удовлетворяет условию, то программа вычисляет его куб и выводит результат. Если число не удовлетворяет условию, программа выводит сообщение об этом.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
