
Вопрос задан 04.07.2023 в 03:49.
Предмет Информатика.
Спрашивает Любчак Ася.
ПОМОГИТЕ С ИНФОРМАЬИКОЙ УМОЛЯЮ напишите программу в с++ с <iostream>!!! Напишите программу,
которая принимает от пользователя номер месяца и сообщает время года, к которому этот месяц относится. Если номер месяца неправильный, то должно быть выведено "Ошибка". Задача должна быть решена с использованием оператора switch.

Ответы на вопрос

Отвечает Тишкова Злата.
Код
- #include <iostream>
- #include <functional>
- std::string what_season_is_it(int month_number) {
- switch (month_number) {
- case 12:
- case 1:
- case 2:
- return "Зима";
- case 3:
- case 4:
- case 5:
- return "Весна";
- case 6:
- case 7:
- case 8:
- return "Лето";
- case 9:
- case 10:
- case 11:
- return "Осень";
- default:
- throw std::runtime_error("You can't stay here. Keep out!!");
- }
- }
- bool take_correct_number(int &number, const std::function<bool(int)>& Q) {
- do {
- std::cin >> number;
- if (!Q(number)) {
- std::cout << "Ошибка" << std::endl;
- continue;
- }
- break;
- } while (true);
- return true;
- }
- int main() {
- int month_number;
- take_correct_number(month_number, [](int x){return x <= 12 && x >= 1;});
- std::cout << what_season_is_it(month_number) << std::endl;
- }





Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я помогу вам написать программу на C++, которая выполняет указанную задачу с использованием оператора switch
. Вот пример программы:
cpp#include <iostream>
int main() {
int month;
std::cout << "Введите номер месяца (1-12): ";
std::cin >> month;
switch (month) {
case 12:
case 1:
case 2:
std::cout << "Зима" << std::endl;
break;
case 3:
case 4:
case 5:
std::cout << "Весна" << std::endl;
break;
case 6:
case 7:
case 8:
std::cout << "Лето" << std::endl;
break;
case 9:
case 10:
case 11:
std::cout << "Осень" << std::endl;
break;
default:
std::cout << "Ошибка" << std::endl;
break;
}
return 0;
}
Эта программа позволяет пользователю ввести номер месяца, а затем с помощью оператора switch
определить соответствующее время года или вывести "Ошибка", если номер месяца не входит в диапазон от 1 до 12.


Похожие вопросы
Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili