 
Вопрос задан 03.07.2023 в 03:19.
Предмет Информатика.
Спрашивает Бирмахан Айдана.
Составить программу: 1. В массиве из 40 случайных чисел из диапазона [-15;15]посчитать количество
единиц; определить каких чисел больше - положительных или отрицательных чисел и на сколько. 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Чиркова Валерия.
                
    ##
var a := ArrRandom(40, -15, 15);
a.Println;
a.Count(p -> p = 1).Println; // количество единиц
var d := a.Count(p -> p > 0) - a.Count(p -> p < 0);
case Sign(d) of
-1: Print('Отрицательных больше на', -d);
0: Print('Отрицательных и положительных поровну');
1: Print('Положительных больше на', d)
end

 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Конечно, вот пример программы на Python, которая выполняет указанные действия:
pythonimport random
# Создаем массив из 40 случайных чисел в диапазоне [-15, 15]
array = [random.randint(-15, 15) for _ in range(40)]
# Инициализируем переменные для подсчета единиц, положительных и отрицательных чисел
count_ones = 0
count_positive = 0
count_negative = 0
# Проходим по массиву и выполняем необходимые подсчеты
for num in array:
    if num == 1:
        count_ones += 1
    if num > 0:
        count_positive += 1
    elif num < 0:
        count_negative += 1
# Определяем, каких чисел больше - положительных или отрицательных, и на сколько
if count_positive > count_negative:
    comparison = "положительных"
    difference = count_positive - count_negative
elif count_positive < count_negative:
    comparison = "отрицательных"
    difference = count_negative - count_positive
else:
    comparison = "одинаковое количество положительных и отрицательных"
    difference = 0
# Выводим результаты
print("Количество единиц в массиве:", count_ones)
print("Больше", comparison, "чисел на", difference)
Программа создает массив из 40 случайных чисел, затем проходит по массиву, подсчитывает количество единиц, положительных и отрицательных чисел, определяет, каких чисел больше, и выводит результаты.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			