
PASCAL. Задание по строкам. Напишите программу, которая переводит натуральное число N ( 1 ≤ N ≤
3999 ) из римской системы счисления в десятичную. Входные данные Входная строка содержит число N , записанное в римской системе счисления. Выходные данные Программа должна вывести десятичную запись числа N . Пример: Ввод MCMLXIX Вывод 1969 Ввод CDLIV Вывод 454 Ввод DCCCXVII Вывод 817

Ответы на вопрос

program rome_arabic;
Uses crt;
Const
{римские цифры}
RomeDigits:string='IVXLCDM';
{числа - соответствующие римским цифрам}
ArabicNumbers:array [1..7] of integer =
(1, 5, 10, 50, 100, 500, 1000);
(*---------------------------------------------------
Функция определения правильности ввода арабского числа
----------------------------------------------------*)
function IsArabic(s:string):boolean;
var i,t,c:integer;
begin
IsArabic:=true;
for i:=1 to length(s) do
if not(s[i] in ['0'..'9'])then
begin
IsArabic:=false;
exit;
end;
val(s,t,c);
if (c<>0)or(t<1) then
begin
IsArabic:=false;
exit;
end;
end;
(*----------------------------------------
Функция перевода арабского числа в римское
----------------------------------------*)
function ArabicToRome (s: string): string;
var
i,n,c: integer;
res: string;
begin
val(s,n,c);
res:='';
i:=7; {Проверяем от больших чисел к меньшим}
while n>0 do
begin
{находим следующее число - из которого будем формировать римскую цифру}
while ArabicNumbers[i]>n do i:=i-1;
res:=res+RomeDigits[i];
n:=n-ArabicNumbers[i];
end;
ArabicToRome := res;
end;
(*---------------------------------------------------
Функция определения правильности ввода римского числа
----------------------------------------------------*)
function IsRome(s:string):boolean;
var i:integer;
begin
IsRome:=true;
if s='' then
begin
IsRome:=false;
exit;
end;
for i:=1 to length(s) do
if not (s[i] in ['I', 'V', 'X', 'L', 'C', 'D', 'M']) then
begin
IsRome:=false;
break;
end;
end;
(*----------------------------------------
Функция перевода римского числа в арабское
----------------------------------------*)
function RomeToArabic (s: string): integer;
var
b:array[1..100] of integer;
i,j:integer;
res:integer;
begin
for i:=1 to length(s) do
begin
if s[i]='I' then b[i]:=1;
if s[i]='V' then b[i]:=5;
if s[i]='X' then b[i]:=10;
if s[i]='L' then b[i]:=50;
if s[i]='C' then b[i]:=100;
if s[i]='D' then b[i]:=500;
if s[i]='M' then b[i]:=1000;
end;
res:=b[1];{массив локальная переменная и
сравнение первого элемента с нулевым искажает число,
почему-то считает, что b[0]=1 и автоматом вычитает 2}
for i:=2 to length(s) do
begin
res:=res+b[i];
if b[i-1]<b[i] then res:=res-2*b[i-1]{вот здесь}
end;
RomeToArabic:=res;
end;
{Основная программа}
var
arabic: string; {арабское число}
rome: string; {римское число}
ask: char; {режим перевода чисел}
begin
clrscr;
writeln('Программа переводит римское число в арабское или арабское в римское');
repeat
clrscr;
writeln('Выберите режим перевода:');
writeln('1 - римское число в арабское');
writeln('2 - арабское число в римское');
writeln('другое - выход');
ask:=readkey;
case ask of
'1': begin {Римское в арабское}
write('Введите римское число: ');
readln(rome);
if IsRome(rome) then
writeln('Арабское число = ',RomeToArabic(rome))
else writeln('В римской записи числа допущены ошибки! Перевод не возможен!');
writeln('Press Enter...');
readln
end;
'2':begin {арабское в римское}
write('Введите арабское число: ');
readln(arabic);
if IsArabic(arabic) then
writeln('Римская запись = ',ArabicToRome(arabic))
else writeln('В арабской записи числа допущены ошибки! Перевод не возможен!');
writeln('Press Enter...');
readln
end;
else exit;
end;
until not(ask in ['1','2']);
end.



Вот пример программы на Pascal, которая выполняет перевод из римской системы счисления в десятичную:
pascalprogram RomanToDecimal; var RomanNumeral: string; RomanValues: array['I'..'M'] of Integer; // Массив значений римских цифр function RomanToDecimalConversion(roman: string): Integer; var i: Integer; begin Result := 0; for i := 1 to Length(roman) do begin if i < Length(roman) then begin if RomanValues[roman[i]] < RomanValues[roman[i+1]] then Result := Result - RomanValues[roman[i]] else Result := Result + RomanValues[roman[i]]; end else Result := Result + RomanValues[roman[i]]; end; end; begin // Инициализация значений римских цифр RomanValues['I'] := 1; RomanValues['V'] := 5; RomanValues['X'] := 10; RomanValues['L'] := 50; RomanValues['C'] := 100; RomanValues['D'] := 500; RomanValues['M'] := 1000; // Ввод римского числа Write('Введите римское число: '); Readln(RomanNumeral); // Вызов функции конвертации и вывод результата Writeln('Десятичное значение: ', RomanToDecimalConversion(RomanNumeral)); end.
Программа сначала инициализирует массив RomanValues
, который содержит значения для каждой римской цифры. Затем она считывает входное римское число, вызывает функцию RomanToDecimalConversion
для выполнения конвертации, и выводит полученный результат.


Похожие вопросы







Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili