Вопрос задан 02.07.2023 в 10:15. Предмет Информатика. Спрашивает Силюкова Юля.

Все по порядку(Язык программирования Python) На вход подается строка, состоящая из двух слов,

разделенных пробелами. Необходимо переставить эти слова в порядке убывания их длин. Формат ввода: строка из двух слов Формат вывода: строка, содержащее то же самое количество слов, но расставленных в порядке убывания их длин
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Александров Матвей.

Ответ:

x =  input()

l = [str(i) for i in x.split(" ")]

res1=l[0]

res2=l[1]

if len(res1) < len(res2):

   print(res2, res1)

if len(res1) > len(res2):

   print(res1, res2)

Пример входа: app down

Вывод: down app

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример кода на Python, который выполняет описанную вами задачу:

python
def rearrange_words(input_str): words = input_str.split() # Разделяем строку на слова words.sort(key=len, reverse=True) # Сортируем слова по убыванию их длин result = ' '.join(words) # Объединяем отсортированные слова обратно в строку return result # Ввод данных от пользователя input_string = input("Введите строку из двух слов, разделенных пробелом: ") # Вызываем функцию для перестановки и вывода результата rearranged_string = rearrange_words(input_string) print("Результат:", rearranged_string)

Вы можете запустить этот код, ввести строку из двух слов, разделенных пробелом, и он выведет результат, в котором слова будут расставлены в порядке убывания их длин.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос