Вопрос задан 09.06.2018 в 08:27. Предмет Информатика. Спрашивает Хворостова Виктория.

Уровень B. На вход программы подаются данные о результатах районной олимпиады. В первой строке –

количество участников N, а следующие N строк имеют следующий формат: <Фамилия> <Имя> <Баллы> Здесь <Фамилия> – строка, состоящая не более чем из 20 символов; <Имя> – строка, состоя-щая не более чем из 15 символов; <Баллы> – целое число, обозначающее общее количество баллов, набранное участником. Все данные разделены пробелами. Пример входной строки: Петечкин Вася 152 Уровень B. На вход программы подаются данные о результатах районной олимпиады. В первой строке – количество участников N, а следующие N строк имеют следующий формат: <Фамилия> <Имя> <Баллы> Здесь <Фамилия> – строка, состоящая не более чем из 20 символов; <Имя> – строка, состоя-щая не более чем из 15 символов; <Баллы> – целое число, обозначающее общее количество баллов, набранное участником. Все данные разделены пробелами. Пример входной строки: Петечкин Вася 152 Чтобы на городскую олимпиаду проходят участники, набравшие в сумме более 100 баллов. Требуется вывести список участников, прошедших на городскую олимпиаду (известно, что их не более 25).
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Гребенников Максим.

// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadlnInteger;
  var a:=ReadArrString(n);
  Writeln(40*'-');
  foreach var w in a do begin
    var wa:=w.ToWords;
    if wa[2].ToInteger>100 then Writeln(w)
    end
end.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос