Срочно! напишите программу, которая анализирует число и определяет положительное оно или
отрицательное. число вводится с клавиатурыОтветы на вопрос
# python
n = float(input('enter a number: '))
if n >= 0:
print('число положительное')
else:
print('число отрицательное')
Ответ:
program Chernovik;
var a: integer;
begin
write ('Введите целое число: ');
readln (a);
if a > 0 then write(a,' - положительное число');
if a < 0 then write(a,' - отрицательное число')
end.
Объяснение:
Вводим число
Если число больше 0, то выводим, что число положительное
Если число меньше 0, то выводим, что число отрицательное
Если число равно 0, то ничего не выводим, т.к. 0 не является ни положительным, ни отрицательным числом
Конечно, вот простая программа на Python, которая позволяет вам ввести число с клавиатуры и определить, является ли оно положительным или отрицательным:
python# Ввод числа с клавиатуры
number = float(input("Введите число: "))
# Проверка, является ли число положительным, отрицательным или нулем
if number > 0:
print("Число положительное")
elif number < 0:
print("Число отрицательное")
else:
print("Число равно нулю")
Просто скопируйте этот код и вставьте его в вашу среду программирования на Python, а затем выполните программу. Она запросит вас ввести число, после чего определит его знак и выведет соответствующее сообщение.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
