C++ Напишите программу, которая переводит переданное её целое число (возможно, отрицательное) в
двоичный код. Используйте процедуру. Примеры входные данные 5 выходные данные 101 входные данные -14 выходные данные -1110Ответы на вопрос
Код программы:
#include <iostream>
#include <locale>
#include <time.h>
using namespace std;
int bit(int a) {
int sum = 0, p = 1;
while (a) {
sum += p * (a % 2);
p *= 10;
a /= 2;
}
return sum;
}
int main()
{
setlocale(LC_ALL, "Russian");
int a;
cout << "Введите число: ";
cin >> a;
cout<<"Число в 2-ой системе счисления: "<<bit(a)<<endl;
}
Для перевода целого числа в двоичный код в C++ можно использовать следующую программу с процедурой:
cpp#include <iostream>
#include <string>
void intToBinary(int num) {
if (num == 0) {
std::cout << "0";
return;
}
bool isNegative = false;
if (num < 0) {
isNegative = true;
num = -num;
}
std::string binary = "";
while (num > 0) {
int remainder = num % 2;
binary = std::to_string(remainder) + binary;
num /= 2;
}
if (isNegative) {
binary = "-" + binary;
}
std::cout << binary;
}
int main() {
int num;
std::cout << "Введите целое число: ";
std::cin >> num;
std::cout << "Двоичное представление: ";
intToBinary(num);
std::cout << std::endl;
return 0;
}
Программа сначала проверяет, является ли число отрицательным, и если да, то устанавливает флаг isNegative и изменяет знак числа на положительный для выполнения вычислений. Затем она делит число на 2 до тех пор, пока оно не станет равным 0, записывая остатки от деления в строку binary. Если число было отрицательным, результат будет иметь префикс "-" для обозначения отрицательности.
Пример ввода/вывода:
Введите целое число: 5 Двоичное представление: 101 Введите целое число: -14 Двоичное представление: -1110
Эта программа позволит вам переводить целые числа в двоичный код с использованием процедуры.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
