Вопрос задан 14.05.2018 в 23:05. Предмет Информатика. Спрашивает Савицкая Лера.

Напишите программу(НА ПИТОНЕ), которая переводит переданное её целое число (возможно,

отрицательное) в двоичный код. Используйте процедуру. Программа должна вывести двоичное представление переданного её числа. Примеры входные данные 5 выходные данные 101 входные данные -14 выходные данные -1110 (НА ПИТОНЕ!!!!!!)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Загородна Оксана.

# Как я понял, для отрицательного числа просто добавляется
# знак -

def IntToByte(x):
    n = "" if x>0 else "0"
    while x > 0:
        y = str(x % 2)
        n = y + n
        x = int(x / 2)
    print (n)
a = int(input())
if a>=0:
    IntToByte(a)
else:
    print('-',end = "")
    IntToByte(-a)


0 0

Последние заданные вопросы в категории Информатика

Задать вопрос