На С++ Напишите программу, которая переводит переданное её целое число (возможно, отрицательное) в
двоичный код. Используйте процедуру. Входные данные Входная строка содержит целое число N . Выходные данные Программа должна вывести двоичное представление переданного её числа. Примеры входные данные 5 выходные данные 101 входные данные -14 выходные данные -1110Ответы на вопрос
#include <iostream>
using namespace std;
long long convert(int n)
{
long long binaryNumber = 0;
int remainder, i = 1;
while (n!=0)
{
remainder = n%2;
n /= 2;
binaryNumber += remainder*i;
i *= 10;
}
return binaryNumber;
}
int main()
{
size_t num;
cin >> num;
cout << convert(num);
}
Программа на C++ для перевода целого числа в двоичный код
```cpp
#include
void decimalToBinary(int n) { std::string binary = ""; bool isNegative = false;
// Check if the number is negative if (n < 0) { isNegative = true; n = -n; }
// Convert decimal to binary while (n > 0) { binary = std::to_string(n % 2) + binary; n /= 2; }
// Add a negative sign if necessary if (isNegative) { binary = "-" + binary; }
// Print the binary representation std::cout << binary << std::endl; }
int main() { int number; std::cout << "Enter an integer: "; std::cin >> number;
decimalToBinary(number);
return 0; } ```
Примеры: - Входные данные: 5 - Выходные данные: 101 - Входные данные: -14 - Выходные данные: -1110
Объяснение программы: - Программа принимает целое число от пользователя. - Затем она вызывает функцию `decimalToBinary`, которая преобразует число в двоичное представление. - В функции `decimalToBinary`: - Мы создаем пустую строку `binary`, в которую будем добавлять цифры двоичного числа. - Проверяем, является ли число отрицательным. Если да, то устанавливаем флаг `isNegative` в `true` и меняем знак числа на положительный. - Затем мы выполняем деление числа на 2 и добавляем остаток в начало строки `binary`. - Повторяем этот процесс до тех пор, пока число не станет равным 0. - Если число было отрицательным, добавляем знак "-" в начало строки `binary`. - Наконец, выводим полученное двоичное представление на экран.
Примечание: - Данная программа реализована на языке C++. - Входные данные принимаются от пользователя через стандартный ввод (консоль). - Выходные данные выводятся на экран с помощью функции `std::cout`.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
