Вопрос задан 26.06.2023 в 20:16.
Предмет Информатика.
Спрашивает Карамышев Данис.
Напишите на c++, пожалуйста.Напишите программу, которая находит в массиве номера элементов, равных
минимальному. Входные данныеПервая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 .Выходные данныеПрограмма должна вывести в одной строке номера элементов массива, равных минимальному, разделив их пробелами.Ответы на вопрос
Отвечает Денисенко Богдан.
#include <iostream>
using namespace std;
int main() {
int N, min;
cin >> N;
int* array = new int[N];
for (int i = 0; i < N; i++)
cin >> array[i];
min = array[0];
for (int i = 1; i < N; i++) {
if (array[i] < min)
min = array[i];
}
for (int i = 0; i < N; i++) {
if (array[i] == min)
cout << i+1 << " ";
}
delete[] array;
return 0;
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на C++, которая решает задачу:
cpp#include <iostream>
#include <vector>
int main() {
int N;
std::cin >> N;
std::vector<int> arr(N);
// Ввод элементов массива
for (int i = 0; i < N; ++i) {
std::cin >> arr[i];
}
// Находим минимальный элемент и его индекс
int min_element = arr[0];
for (int i = 1; i < N; ++i) {
if (arr[i] < min_element) {
min_element = arr[i];
}
}
// Находим индексы элементов, равных минимальному
std::vector<int> indices;
for (int i = 0; i < N; ++i) {
if (arr[i] == min_element) {
indices.push_back(i + 1); // +1 для перевода из нулевого индекса в естественный номер элемента
}
}
// Выводим найденные индексы
for (int i = 0; i < indices.size(); ++i) {
std::cout << indices[i] << " ";
}
return 0;
}
Программа сначала считывает размер массива N, затем сам массив. Затем она находит минимальный элемент и сохраняет его индекс в вектор indices. Наконец, программа выводит индексы элементов, равных минимальному.
Пример входных данных:
5 3 1 4 1 5
Пример выходных данных:
2 4
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
