Вопрос задан 30.12.2018 в 07:56. Предмет Информатика. Спрашивает Игнатьев Илья.

Программа на с++ Напишите программу, которая находит в массиве минимальный и максимальный из чётных

положительных элементов. Входные данные Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 . Выходные данные Программа должна вывести в одной строке минимальный и максимальный из чётных положительных элементов массива, разделив их пробелом. Если в массиве нет чётных положительных элементов, программа должна вывести два числа -1. Примеры входные данные 6 -2 -1 2 3 5 6 выходные данные 2 6
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Гузов Егор.
#include <iostream>

using namespace std;

int main() {
int n;
 cin >> n;
 int *arr = new int[n];

for (int i = 0; i < n; i++) {
 cin >> arr[i];
}

int max = -1;
int min = -1;

for (int i = 1; i < n; i++) {
  if (arr[i] > 0 && arr[i] % 2 == 0) {
  if (min == -1) {
   min = arr[i];
  }
  if (max < arr[i]) {
    max = arr[i];
  }
   if (min > arr[i]) {
   min = arr[i];
  }
  }
 }
 cout << min << " " << max;
system("pause");
return 0;}

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос