Вопрос задан 26.06.2023 в 17:24. Предмет Информатика. Спрашивает Асланов Мухаммед.

на С++ написать программу, которая выводит заданное число на экран, а также сумму и произведение

его цифр.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Наумов Дима.

Ответ:

#include <iostream>

using namespace std;

int main()

{

setlocale(LC_ALL, "russian");

int n, a=0, b=1;

cin >> n;

while (n > 0)

{

a += n % 10;

b *= n % 10;

n = n / 10;

}

cout << "Сумма цифр равна:" << a << "\nПроизведение цифр равно:" << b;

}

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на C++, которая выводит заданное число на экран, а также вычисляет сумму и произведение его цифр:

cpp
#include <iostream> int main() { // Объявляем переменные для числа, суммы и произведения его цифр int number, sum = 0, product = 1; // Вводим число с клавиатуры std::cout << "Введите число: "; std::cin >> number; // Сохраняем оригинальное число для вычисления произведения int originalNumber = number; // Вычисляем сумму и произведение цифр числа while (number != 0) { int digit = number % 10; // Получаем последнюю цифру числа sum += digit; // Добавляем цифру к сумме product *= digit; // Умножаем цифру на текущее произведение number /= 10; // Убираем последнюю цифру из числа } // Выводим результаты на экран std::cout << "Введенное число: " << originalNumber << std::endl; std::cout << "Сумма цифр: " << sum << std::endl; std::cout << "Произведение цифр: " << product << std::endl; return 0; }

Эта программа запрашивает у пользователя ввод числа, вычисляет сумму и произведение его цифр, а затем выводит результаты на экран.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос