Вопрос задан 26.06.2023 в 14:57. Предмет Информатика. Спрашивает Сокольчик Дима.

Составить программу, которая переворачивает слово наоборот, если оно состоит из 4 букв. Паскаль

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Добрева Аня.

var str:string;

begin

 write('Введите слово: ');

 readln(str);

 var reverse_str:= '';

 if str.Length = 4 then begin

                           for var i:= str.Length downto 1 do

                             reverse_str:= reverse_str + str[i];

                           writeln(reverse_str);

                        end

                   else writeln('Слово состоит НЕ из 4 букв');

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вы можете использовать следующую программу на языке Pascal, чтобы перевернуть слово наоборот, если оно состоит из четырех букв:

pascal
program ReverseWord; var InputWord, ReversedWord: string; begin // Введите слово Write('Введите слово: '); Readln(InputWord); // Проверяем, состоит ли слово из 4 букв if Length(InputWord) = 4 then begin // Переворачиваем слово ReversedWord := InputWord[4] + InputWord[3] + InputWord[2] + InputWord[1]; WriteLn('Перевернутое слово: ', ReversedWord); end else begin WriteLn('Слово не состоит из 4 букв и не будет перевернуто.'); end; end.

Скопируйте этот код в среду разработки Pascal и выполните программу. Она попросит вас ввести слово, и если оно состоит из четырех букв, оно будет перевернуто и выведено на экран. Если слово имеет другую длину, программа сообщит вам, что оно не будет перевернуто.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос