Уровень B. Напишите программу, которая получает день и номер месяца и определяет дату следующего
дня. Считайте, что год невисокосный (365 дней). Пример: Введите день и месяц: 25 12 Следующий день: 26 декабря Пример: Введите день и месяц: 28 2 Следующий день: 1 мартаОтветы на вопрос
Ответ:
Var
День,Месяц:byte;
Begin
Write('№ дня = ');ReadLn(День);
Var C:=365-День;
Write('№ месяца = ');ReadLn(Месяц);
Case Месяц of
2:C:=C-31;
3:C:=C-59;
4:C:=C-90;
5:C:=C-120;
6:C:=C-151;
7:C:=C-181;
8:C:=C-212;
9:C:=C-243;
10:C:=C-273;
11:C:=C-304;
12:C:=C-334
End;
if (C mod 100>10)and(C mod 100<20) then Write('До нового года осталось ',C,' дней')
else
Case C mod 10 of
1:Write('До нового года остался ',C,' день');
2..4:Write('До нового года осталось ',C,' дня');
0,5..9:Write('До нового года осталось ',C,' дней')
End
End
Объяснение:
Для создания программы на уровне B, которая будет определять дату следующего дня на основе введенного дня и номера месяца, вы можете использовать следующий код на Python:
python# Получение дня и номера месяца от пользователя
day = int(input("Введите день: "))
month = int(input("Введите номер месяца: "))
# Проверка на корректность введенных данных
if month < 1 or month > 12 or day < 1 or day > 31:
print("Некорректная дата")
else:
# Определение максимального числа дней в месяце
max_days_in_month = 31
if month == 4 or month == 6 or month == 9 or month == 11:
max_days_in_month = 30
elif month == 2:
max_days_in_month = 28
# Проверка на корректный день
if day <= max_days_in_month:
# Вычисление следующей даты
next_day = day + 1
next_month = month
if next_day > max_days_in_month:
next_day = 1
next_month += 1
# Словарь для преобразования номера месяца в название
months = {
1: "января",
2: "февраля",
3: "марта",
4: "апреля",
5: "мая",
6: "июня",
7: "июля",
8: "августа",
9: "сентября",
10: "октября",
11: "ноября",
12: "декабря"
}
# Вывод результата
print(f"Следующий день: {next_day} {months[next_month]}")
else:
print("Некорректный день для выбранного месяца")
Этот код сначала запрашивает у пользователя день и номер месяца, затем проверяет их на корректность, учитывая максимальное количество дней в месяце. После этого код вычисляет следующий день и месяц, и выводит результат в желаемом формате.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
