Вопрос задан 08.01.2020 в 20:49. Предмет Информатика. Спрашивает Nurseit Beka.

Напишите программу в Паскаль, которая получает день и номер месяца, а выводит количество дней,

оставшихся до Нового Года. Считайте, что год невисокосный (365 дней). Учтите, что слово "дней" может иметь также формы "день" и "дня". Пример: Введите день и месяц: 25 12 Осталось 7 дней до Нового Года. Пример: Введите день и месяц: 1 1 Осталось 364 дня до Нового Года. Пример: Введите день и месяц: 31 2 Неверная дата.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Сенаторов Коля.
//PascalABC
Uses System;
var day, month: integer;
begin
  Read(day, month);    var d := new DateTime(DateTime.Now.Year, month, day);    var new_year := new DateTime(d.Year+1, 1, 1);    Writeln((new_year - d).TotalDays);  end.
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос