Вопрос задан 26.06.2023 в 09:28. Предмет Информатика. Спрашивает Чечуй Богдан.

Python. Циклы for и while. Напишите программу, которая в последовательности натуральных чисел

находит среднее арифметическое трёхзначных чисел или сообщает, что таких чисел нет (выводит NO). Последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). 30 б.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Уфимцева Инна.

x, s, counter = -1, 0, 0

while x != 0:

   x = int(input())

   if (x>=100) and (x<=999):

       s += x

       counter += 1

if counter == 0:

   print("NO")

else:

   print(s/counter)

0 0
Отвечает Вольников Ярослав.

numbers = []

while True:

   num = int(input('Введите число: '))

   if num == 0:

       break

   if len(str(num)) == 3:

       numbers.append(num)

if numbers != []:

   s = 0

   for num in numbers:

       s += num

   print('Среднее арифметическое:', s / len(numbers))

else:

   print('NO')

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи, вам нужно будет использовать цикл while, чтобы считывать числа из последовательности и проверять их на соответствие условиям (трёхзначные числа), а также считать их сумму и количество, чтобы потом вычислить среднее арифметическое. Вот пример программы на Python:

python
# Инициализируем переменные для суммы и количества трёхзначных чисел total = 0 count = 0 # Считываем первое число number = int(input("Введите число (0 для завершения): ")) # Пока введённое число не равно 0 while number != 0: # Проверяем, что число трёхзначное if 100 <= number <= 999: # Если число трёхзначное, добавляем его к сумме total += number # Увеличиваем счётчик на 1 count += 1 # Считываем следующее число number = int(input("Введите число (0 для завершения): ")) # Проверяем, были ли трёхзначные числа if count > 0: # Вычисляем среднее арифметическое average = total / count print("Среднее арифметическое трёхзначных чисел:", average) else: print("Нет трёхзначных чисел в последовательности.")

Эта программа считывает числа до тех пор, пока не будет введен 0, проверяет каждое число на соответствие требованиям (трёхзначное), и если такие числа найдены, вычисляет и выводит среднее арифметическое. Если трёхзначные числа не найдены, программа выводит "Нет трёхзначных чисел в последовательности."

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос