Вопрос задан 16.06.2023 в 08:06. Предмет Информатика. Спрашивает Варченя Никита.

Язык Python Напишите программу, которая в последовательности натуральных чисел находит среднее

арифметическое чисел, кратных 8, или сообщает, что таких чисел нет (выводит «NO»). Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести среднее арифметическое чисел, кратных 8, или вывести «NO», если таких чисел нет. Значение выводить с точностью до десятых.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Алтаев Диас.

import math

rostList = input('Вводить числа через пробел: ')

rostList = rostList.split(' ')[::1]

rostList = list(map(lambda x: int(x), rostList))

print('Массив (список): ', rostList)

if ((len(rostList)) < 100):

   print('good')

   for i in rostList:

       if (i < 300):

           krat_8 = []

           summ = 0

           for i in rostList:

               if i % 8 == 0:

                   krat_8.append(i)

   print('Числа кратные 8: ', krat_8)

   for i in krat_8:

       summ += i

       summ = summ / len(krat_8)

   print('Среднее арифмтическое чисел кратных 8: ', round(summ, 2))

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на языке Python, которая решает данную задачу:

python
numbers = [] # список для хранения введенных чисел # Ввод чисел while True: num = int(input("Введите число (для завершения введите 0): ")) if num == 0: break numbers.append(num) # Поиск чисел, кратных 8 multiples_of_eight = [num for num in numbers if num % 8 == 0] # Проверка наличия чисел, кратных 8 if len(multiples_of_eight) == 0: print("NO") else: # Вычисление среднего арифметического average = sum(multiples_of_eight) / len(multiples_of_eight) print("Среднее арифметическое чисел, кратных 8:", round(average, 1))

Программа запрашивает у пользователя ввод чисел до тех пор, пока не будет введено число 0. Затем она создает список multiples_of_eight, содержащий только числа, кратные 8, из списка numbers. Если список multiples_of_eight пуст (длина равна 0), программа выводит "NO". В противном случае, программа вычисляет среднее арифметическое чисел в списке multiples_of_eight и выводит его с точностью до десятых.

0 0

Похожие вопросы

Последние заданные вопросы в категории Информатика

Задать вопрос