Написать программу Pascal для нахождения наибольшей цифры целого положительного числа. Длина числа
до 9 цифр. Ответы на вопрос
var
a: string;
b: array[1..9]of integer;
sort: boolean;
max, k: integer;
begin
Readln(a);
for var i := 1 to Length(a) do
b[i] := strtoint(a[i]);
sort := false;
while sort = false do
begin
sort := true;
k += 1;
for var i := 1 to Length(a)-1 do
begin
if a[i] < a[i+1] then
begin
sort := false;
var value2 := a[i];
a[i] := a[i+1];
a[i+1] := value2;
end;
end;
end;
write(a[1]);
end.
Программа написана на PascalABC.net
на free pascal или turbo pascal она может не работать
Конечно, вот пример программы на Pascal, которая находит наибольшую цифру в заданном положительном числе:
pascalprogram FindLargestDigit; var num, largestDigit, currentDigit: integer; begin // Вводим положительное число writeln('Введите целое положительное число:'); readln(num); // Инициализируем переменную largestDigit нулем largestDigit := 0; // Проверяем каждую цифру в числе while num > 0 do begin // Получаем текущую цифру, выделяя ее из числа currentDigit := num mod 10; // Если текущая цифра больше наибольшей найденной цифры, обновляем largestDigit if currentDigit > largestDigit then largestDigit := currentDigit; // Убираем последнюю цифру из числа num := num div 10; end; // Выводим наибольшую цифру writeln('Наибольшая цифра в числе: ', largestDigit); end.
Эта программа сначала запрашивает у пользователя положительное число, затем с помощью цикла while проверяет каждую цифру в числе и находит наибольшую из них. Наконец, программа выводит наибольшую цифру на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
