Вопрос задан 25.06.2023 в 23:54. Предмет Информатика. Спрашивает Виноградов Данил.

СРОЧНО! 1)Составьте программу  вычисления значения функции y=x3 –x2 +16x-43 для х, меняющего

в диапазоне            от 4 до -4 шагом 0,5.2)Составьте программу, печатающую все простые числа, не превосходящие заданное число.​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Перепелица Дарья.

python

1)

from numpy import arange # нужно установить библиотеку numpy

for x in arange(4, -4, -0.5):

   print('x =', str(x) + ' :', x * 3 - x * 2 + 16 * x - 43)

2)

number = int(input('Введите число: '))

primeNumbers = []

for i in range(1, number + 1):

   numberDividers = 0

   for z in range(1, i + 1):

       if i / z == i // z:

           numberDividers += 1

   

   if numberDividers == 2:

      primeNumbers.append(i)

if len(primeNumbers) == 0:

   print('Нет простых чисел до числа ' + str(number))

else:

   print('Простые числа:')

   for i in primeNumbers:

       print(i)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для выполнения данных задач, предлагаю использовать язык программирования Python. Вот программы для каждой из задач:

  1. Программа для вычисления значения функции y = x^3 - x^2 + 16x - 43 для x в диапазоне от 4 до -4 с шагом 0.5:
python
# Задаем начальное и конечное значение x, а также шаг start_x = 4 end_x = -4 step = 0.5 # Цикл для перебора значений x и вычисления функции y x = start_x while x >= end_x: y = x**3 - x**2 + 16*x - 43 print(f"x = {x}, y = {y}") x -= step
  1. Программа для вывода всех простых чисел, не превосходящих заданного числа:
python
# Функция для проверки, является ли число простым def is_prime(n): if n <= 1: return False elif n <= 3: return True elif n % 2 == 0 or n % 3 == 0: return False i = 5 while i * i <= n: if n % i == 0 or n % (i + 2) == 0: return False i += 6 return True # Запрос пользователя для ввода верхнего предела limit = int(input("Введите верхний предел: ")) # Цикл для вывода всех простых чисел до заданного предела print("Простые числа:") for num in range(2, limit + 1): if is_prime(num): print(num, end=" ")

Скопируйте соответствующую программу в вашу среду разработки или интерпретатор Python и выполните её для получения результатов.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос