
C++Написать программу которая заполняет рандомно массив и считает сумму этих чисел


Ответы на вопрос

#include <iostream>
#include <cstdlib>
#include <ctime>
typedef int datatype;
void init_array(datatype* arr, int SIZE)
{
for (int i = 0; i < SIZE; ++i)
arr[i] = rand() % 100;
}
void show_array(datatype* arr, int SIZE)
{
std::cout << "array: ";
for (int i = 0; i < SIZE; ++i)
std::cout << arr[i] << " ";
std::cout << "\n";
}
datatype find_sum(datatype* arr, int SIZE)
{
datatype sum = 0;
for (int i = 0; i < SIZE; ++i)
sum += arr[i];
return sum;
}
int main()
{
std::cout << "enter a size of the array: ";
int SIZE;
std::cin >> SIZE;
datatype *arr = new datatype[SIZE];
srand(time(NULL));
init_array(arr, SIZE);
show_array(arr, SIZE);
std::cout << "sum of elements: " << find_sum(arr, SIZE) << "\n";
delete[] arr;
return 0;
}



Вот пример программы на C++, которая создает массив случайных чисел и затем вычисляет их сумму:
cpp#include <iostream>
#include <cstdlib>
#include <ctime>
using namespace std;
int main() {
// Установка генератора случайных чисел на основе времени
srand(time(0));
int n; // Размер массива
cout << "Введите размер массива: ";
cin >> n;
// Создание массива и заполнение его случайными числами
int* arr = new int[n];
for (int i = 0; i < n; i++) {
arr[i] = rand() % 100; // Генерация случайного числа от 0 до 99
}
// Вычисление суммы чисел в массиве
int sum = 0;
for (int i = 0; i < n; i++) {
sum += arr[i];
}
// Вывод сгенерированного массива
cout << "Сгенерированный массив: ";
for (int i = 0; i < n; i++) {
cout << arr[i] << " ";
}
cout << endl;
// Вывод суммы чисел
cout << "Сумма чисел в массиве: " << sum << endl;
// Освобождение памяти, выделенной для массива
delete[] arr;
return 0;
}
Эта программа сначала запрашивает у пользователя размер массива, затем создает массив заданного размера и заполняет его случайными числами от 0 до 99. Затем она вычисляет сумму всех чисел в массиве и выводит как сам массив, так и сумму на экран. Не забудьте освободить память, выделенную для массива, с помощью оператора delete[]
, чтобы избежать утечки памяти.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili