Паскаль! Надо написать программу используя while-do,программа должна иметь практическое
применение в жизни.Ответы на вопрос
Ответ:
#include <iostream>
using namespace std;
int main ()
{
setlocale(0, "");
int i = 0; // инициализируем счетчик цикла.
int sum = 0; // инициализируем счетчик суммы.
do {// выполняем цикл.
i++;
sum += i;
} while (i < 1000); // пока выполняется условие.
cout << "Сумма чисел от 1 до 1000 = " << sum << endl;
return 0;
}
Объяснение:
Цикл do while
Цикл do while очень похож на цикл while. Единственное их различие в том, что при выполнении цикла do while один проход цикла будет выполнен независимо от условия. Решение задачи на поиск суммы чисел от 1 до 1000, с применением цикла do while.
Принципиального отличия нет, но если присвоить переменной i значение, большее, чем 1000, то цикл все равно выполнит хотя бы один проход.
Конечно, я могу предложить вам программу на языке Паскаль, которая имеет практическое применение в жизни. Давайте напишем программу для вычисления средней оценки студента на основе введенных им оценок.
pascalprogram СредняяОценка; var Оценка, Сумма: Real; КоличествоОценок, Счетчик: Integer; begin Сумма := 0; КоличествоОценок := 0; writeln('Введите оценки студента (для завершения ввода введите отрицательное число): '); readln(Оценка); while Оценка >= 0 do begin Сумма := Сумма + Оценка; КоличествоОценок := КоличествоОценок + 1; readln(Оценка); end; if КоличествоОценок > 0 then begin СредняяОценка := Сумма / КоличествоОценок; writeln('Средняя оценка студента: ', СредняяОценка:0:2); end else writeln('Студент не ввел ни одной оценки.'); readln; end.
Эта программа позволяет студенту вводить свои оценки, и она вычисляет среднюю оценку на основе введенных данных. Это может быть полезным в реальной жизни для отслеживания успеваемости студента.
Вы можете изменить программу или добавить дополнительные функции в зависимости от ваших потребностей.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
