Вопрос задан 24.06.2023 в 20:32. Предмет Информатика. Спрашивает Фалина Арина.

Дан массив из n чисел. Элементы, стоящие на четных местах разделить на 3, а стоящие на нечетных

местах умножить на 2 Помогите написать программу в Питоне
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Мамаева Полина.

a = [float(input()) for i in range(int(input("n=")))]

print(a)

for i in range(0,len(a)):

   if i % 2 == 0:

       a[i] /= 3

   else:

       a[i] *= 2

print(a)

   

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Python, которая выполняет указанные операции над элементами массива:

python
# Вводим массив из n чисел n = int(input("Введите размер массива: ")) array = [] for i in range(n): num = int(input(f"Введите {i + 1}-й элемент массива: ")) array.append(num) # Выполняем операции над элементами массива for i in range(n): if i % 2 == 0: # Если индекс четный (четные места) array[i] /= 3 else: # Если индекс нечетный (нечетные места) array[i] *= 2 # Выводим полученный массив print("Массив после выполнения операций:") print(array)

Программа сначала запрашивает у пользователя размер массива и элементы массива. Затем она выполняет указанные операции над элементами массива в соответствии с их позициями (четные места делятся на 3, нечетные умножаются на 2) и выводит измененный массив.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос