
Программирование на C++. Помогите решить задачу пж!!! Напишите программу, которая в
последовательности целых чисел определяет среднее арифметическое нечетных чисел. Программа получает на вход целые положительные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введенные числа не превышают 10 000. Программа должна вывести одно число: среднее арифметическое нечетных чисел (с точностью до десятых) Пример работы программы Входные данные 7 2 7 0 Выходные данные 7.0

Ответы на вопрос

#include <iostream>
#include <stdio.h>
using namespace std;
int main()
{
int sum=0,n,count=1, count_ch=0;
float result;
cin >> n;
if (n<10000)
{
while (n != 0)
{
if (n % 2 == 0)
{
sum += n;
count_ch++;
}
cin >> n;
count++;
if (n > 10000 or count > 1000)
{
break;
}
}
}
result = sum/count_ch;
printf("%.2f",result);
}






Для решения этой задачи вы можете написать программу на C++. Вот пример программы, которая решает задачу:
cpp#include <iostream>
int main() {
int number;
int sum = 0;
int count = 0;
std::cout << "Введите последовательность целых чисел (0 для завершения ввода):" << std::endl;
while (true) {
std::cin >> number;
if (number == 0) {
break; // Ввод завершен
}
if (number % 2 != 0) { // Проверка на нечетное число
sum += number;
count++;
}
}
if (count > 0) {
double average = static_cast<double>(sum) / count;
std::cout << "Среднее арифметическое нечетных чисел: " << average << std::endl;
} else {
std::cout << "Введено 0 нечетных чисел." << std::endl;
}
return 0;
}
Эта программа будет считывать целые числа до тех пор, пока не будет введен 0. Если число нечетное, оно будет добавлено к сумме, и будет подсчитано количество нечетных чисел. Затем программа вычислит среднее арифметическое нечетных чисел и выведет результат с точностью до десятых.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili