Вопрос задан 24.06.2023 в 14:51. Предмет Информатика. Спрашивает Голицын Александр.

составить программу на языке паскаль среди двузначных нечётных чисел подсчитать количество тех

сумма цифр которых кратна трем ответ
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Исаков Костя.

var i,k,d,e,s:integer;

begin

k:=0;

for i:= 10 to 99 do

if i mod 2 = 1 then

begin

d:=i div 10;

e:=i mod 10;

s:=d+e;

if ((s mod 3) = 0) then

k:=k+1;

end;

writeln(k);

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот программа на языке Pascal, которая выполняет заданную задачу:

pascal
program CountNumbers; var num, digit1, digit2, sum: integer; count: integer; begin count := 0; for num := 11 to 99 step 2 do begin digit1 := num div 10; digit2 := num mod 10; sum := digit1 + digit2; if (sum mod 3 = 0) then begin count := count + 1; writeln(num); end; end; writeln('Количество чисел: ', count); end.

Эта программа сначала инициализирует переменную count как 0. Затем она запускает цикл с переменной num в пределах от 11 до 99 с шагом 2, чтобы перебрать все двузначные нечетные числа.

Внутри цикла, программа разбивает число num на две цифры (digit1 и digit2) и суммирует их (sum). Затем она проверяет, делится ли эта сумма на 3. Если да, то увеличивает счетчик count и выводит число num.

В конце программа выводит общее количество чисел, удовлетворяющих условиям задачи.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос