Вопрос задан 24.06.2023 в 05:40. Предмет Информатика. Спрашивает Даулетхан Аружан.

Python ! 1) Сгенерировать список из 10000 случайных элементов, значения от 0 до 99 (через

бибилотеку random), после чего вывести среднее арифметическое этих элементов, сумму всех элементов, которые делятся на 10 без остатка и если сумма этих элементов меньше 600, вывести значение последнего элемента массива. 2) Написать программу, которая на вход получает слово, и добавляет к нему восклицательный знак, выовдит получившуюся строку.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Дюсенова Анель.

1)import random

s = [random.randint(0,99) for i in range(10000)]

sum = 0

for i in s:

   sum += i

print("Среднее арифметическое:", sum/10000)

sum = 0

for i in s:

   if i % 10 == 0:

       sum += i

if sum < 600:

   print(s[len(s)-1])

else:

   print("Сумма всех элементов, которые делятся на 10 без остатка:",sum)

2)s = input()

print(s+"!")

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот код на Python, который реализует оба ваших задания:

  1. Генерация списка из 10000 случайных элементов, вычисление среднего арифметического, суммы элементов, которые делятся на 10, и вывод последнего элемента, если условие выполняется:
python
import random # Генерация списка из 10000 случайных элементов от 0 до 99 random_numbers = [random.randint(0, 99) for _ in range(10000)] # Вычисление среднего арифметического average = sum(random_numbers) / len(random_numbers) # Вычисление суммы элементов, которые делятся на 10 без остатка divisible_by_10_sum = sum(x for x in random_numbers if x % 10 == 0) # Если сумма элементов, которые делятся на 10, меньше 600, вывести последний элемент if divisible_by_10_sum < 600: last_element = random_numbers[-1] print(f"Среднее: {average}") print(f"Сумма элементов, делящихся на 10: {divisible_by_10_sum}") print(f"Последний элемент: {last_element}") else: print(f"Среднее: {average}") print(f"Сумма элементов, делящихся на 10: {divisible_by_10_sum}")
  1. Программа, которая добавляет восклицательный знак к введенному слову и выводит получившуюся строку:
python
# Ввод слова word = input("Введите слово: ") # Добавление восклицательного знака word_with_exclamation = word + "!" # Вывод результата print("Результат:", word_with_exclamation)

Вы можете выполнить каждый из этих кодов в Python для выполнения соответствующего задания.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос