
Вопрос задан 23.06.2023 в 00:33.
Предмет Информатика.
Спрашивает Суслина Дарья.
Написать программу на Паскале Дан массив A целых чисел, содержащий 30 элементов. Вычислить и
вывести сумму тех элементов, которые нечетны и отрицательны.

Ответы на вопрос

Отвечает Сембай Мейрамбек.
const
n=30;
var
a:array [1..n] of integer;
i,sum:integer;
begin
sum:=0;
for i:=1 to n do
begin
a[i]:=random(101)-50;
if (abs(a[i] mod 2) = 1) and (a[i]<0) then
sum:=sum+a[i];
write(a[i]:4);
end;
writeln;
write('sum: ',sum);
end.



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на языке Pascal, которая вычисляет и выводит сумму элементов массива A, которые являются отрицательными и нечетными:
pascalprogram SumNegativeOddElements; var A: array[1..30] of integer; // Объявляем массив A из 30 элементов i, sum: integer; // Переменные для цикла и суммы begin sum := 0; // Инициализируем сумму нулем // Заполняем массив A случайными значениями (замените этот блок на заполнение вашими данными) for i := 1 to 30 do begin A[i] := Random(201) - 100; // Генерируем случайные значения от -100 до 100 end; // Вычисляем сумму отрицательных и нечетных элементов for i := 1 to 30 do begin if (A[i] < 0) and (A[i] mod 2 <> 0) then begin sum := sum + A[i]; end; end; // Выводим результат writeln('Сумма отрицательных и нечетных элементов массива A: ', sum); // Ожидаем нажатия клавиши перед закрытием окна readln; end.
Эта программа сначала заполняет массив A случайными отрицательными и положительными значениями, а затем считает и выводит сумму отрицательных и нечетных элементов этого массива. Вы можете заменить генерацию случайных значений на ввод данных с клавиатуры или другой способ инициализации массива A.


Похожие вопросы
Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili