
Составить программу, находящую сумму всех чисел от 1 до 50. Составить программу, находящую сумму
чётных чисел от 111 до 200. Даны три числа:a,b,c. Удвоить каждое из данных чисел, если c<или=b, b<или=a и заменить числа их модулями в противном случае. Даны два числа:a,b. Вывести на печать первое, если оно>второго и оба числа, если это не так. 

Ответы на вопрос

Язык: Java
1.
public class Sum {
public static void main(String args[]) {
//n — первая граница чисел, sum — сумма чисел; i — складыватель числа n — на саму себя
int n = 0, sum, i = 0;
//i — стремится к 50, каждый раз увеличиваясь на 1 — но одновременно давая своё значение переменной n.
for(; i <= 50; i++) {
n += i;
}
System.out.println(n);
}
}
Output: 1275.
2.
public class Sum1 {
public static void main(String args[]) {
//Одни и те же переменные, но только i — должен быть на 2 больше n, так как в цикле for — подчёт начинается сразу с заранее заданным значением.
int n = 112, sum, i = 114;
//Кстати заметили, что n — начинается не с 111? Потому что в цикле, подчёт, и складывание на 2 — начнётся именно с 111, и в итоге все цифры будут нечётными, поэтому первая цифра должна быть чётной, и больше 111, то есть — 112.
for(; i <= 200; i+=2) {
n += i;
}
System.out.println(n);
}
}
Output: 7020.
3.
Ты имеешь ввиду — вывести в противоном случае все числа — в модулях? Или поменять их знаки, с отрицательного на положительного, и наоборот?
//Создание класса Scanner, для последующих вводов пользователя
import java.util.Scanner;
public class Sum {
public static void main(String args[]) {
int a, b, c;
//Для возможности ввода пользователя, создадим объект "input" класса Scanner
Scanner input = new Scanner(System.in);
//Ввод пользователя
System.out.println("Enter the first number: ");
a = input.nextInt();
System.out.println("\n Enter the second number: ");
b = input.nextInt();
System.out.println("\n Enter the third number: ");
c = input.nextInt();
//Условия, заданные в задаче. Знак "&&" означает "также"
if(c<=b && b<=a) {
a = a*2;
b = b*2;
c = c*2;
}
//Math.abs() — метод, который возвращает абсолютное значение числа, то есть выводит в модуль.
else {
System.out.println("\nThe first number: " + Math.abs(a) + "\nThe second number: " + Math.abs(b) + "\nThe third number: " + Math.abs(c));
}
}
}
4.
import java.util.Scanner;
public class Sum {
public static void main(String args[]) {
//Объявленя двух чисел
int a, b;
Scanner input = new Scanner(System.in);
//Ввод пользователя
System.out.println("The first nubmer: ");
a = input.nextInt();
System.out.println("\nThe second number: ");
b = input.nextInt();
if(a>b) {
System.out.println("\n" + a);
}
else {
System.out.println("\n" + a + "; " + b);
}
}
}



Для каждой из задач, я предоставлю вам программный код на языке Python:
- Найти сумму всех чисел от 1 до 50:
pythonsum_numbers = sum(range(1, 51))
print("Сумма всех чисел от 1 до 50:", sum_numbers)
- Найти сумму четных чисел от 111 до 200:
pythonsum_even_numbers = sum(range(112, 201, 2))
print("Сумма четных чисел от 111 до 200:", sum_even_numbers)
- Удвоить числа a, b, c, если выполняются указанные условия, и заменить числа их модулями в противном случае:
pythona, b, c = 10, 20, 30 # Замените эти значения на ваши
if c <= b and b <= a:
a *= 2
b *= 2
c *= 2
else:
a = abs(a)
b = abs(b)
c = abs(c)
print("a =", a)
print("b =", b)
print("c =", c)
- Вывести первое число, если оно больше второго, и оба числа в противном случае:
pythona, b = 10, 5 # Замените эти значения на ваши
if a > b:
print("Первое число (a) больше второго:", a)
else:
print("Оба числа:", a, b)
Замените значения переменных a, b и c в соответствии с вашей задачей или вводом пользователя, если это необходимо.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili