Вопрос задан 22.06.2023 в 03:35.
Предмет Информатика.
Спрашивает Москалёва Виктория.
Составить программу, которая по введенному времени определяла бы, ночь сейчас или день( считать,
что ночные часы с 23 до 7) написать код на языке ПаскальОтветы на вопрос
Отвечает Соколова Анна.
Ответ:
Pascal
var
a: integer;
begin
writeln('Введите время (часы)');
readln(a);
if (a >= 7) and (a < 23) then
writeln('День')
else
writeln('Ночь');
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Паскаль, которая определяет, ночь ли сейчас, основываясь на введенном времени:
pascalprogram DayOrNight; var Hour: integer; begin write('Введите текущее время (час): '); readln(Hour); if (Hour >= 23) or (Hour < 7) then writeln('Сейчас ночь.') else writeln('Сейчас день.'); end.
Эта программа сначала запрашивает у пользователя ввести текущее время в часах. Затем она использует условный оператор if для проверки, находится ли время в интервале с 23 часов вечера до 7 часов утра. Если время попадает в этот интервал, программа сообщит, что сейчас ночь, в противном случае она скажет, что сейчас день.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
